PowerPad III Control Panel

Ver. 1.07.13010

This control panel supports models: 8333, 8335 (if using firmware >2.8), 8336, 8435, 8436
Download .zip format

This control panel requires Dataview version 3.60.0018 or higher

DataView Ver. 3.61.0008     Release Notes   |   Models Supported by DataView

IMPORTANT:

  • Back-up all template files before installation to ensure that they do not get overwritten.
  • Uninstall previous versions of DataView before installing a new version.
  • PQL Loggers and Sentinel Series are no longer supported by DataView. See bottom of the page for a compatible version
 

Supported Operating Systems:
Windows 7 (32 & 64 Bit)
Windows 8/8.1 (32 & 64 Bit)
Windows 10 (32 & 64 Bit)

Click here for the Minimum System Requirements

DISCOVER THE CHAUVIN® ARNOUX GROUP